A Cars forum. AutoBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » AutoBanter forum » Auto newsgroups » Technology
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

MAF Sensor, I need help



 
 
Thread Tools Display Modes
  #1  
Old April 20th 07, 09:19 PM posted to rec.autos.tech
Dennis[_2_]
external usenet poster
 
Posts: 56
Default MAF Sensor, I need help

My son drives a 1999 Escort ZX2 with the L4 2.0 liter engine. He was
complaining that the car doesn't
have as much power that it used to and that it idles rough. I connected my
scan tool to check things out ( I'm new at this and far from an expert) and
noticed that the mass air flow sensor was 2.7 volts at idle. The specs are
..6-.9 volts.
The calculated engine load was 59.2 % at idle. The long term fuel trim
showed 2.3 %. There were no trouble codes set. Is this enough evidence to
replace the MAF sensor? I hear they aren't cheap so I need a second opinion.
Thanks so much for any help.

Dennis


Ads
  #2  
Old April 20th 07, 09:50 PM posted to rec.autos.tech
maxwedge[_21_]
external usenet poster
 
Posts: 1
Default MAF Sensor, I need help


Clean the element in the maf with CRC ,maf cleaner.


--
maxwedge
------------------------------------------------------------------------
maxwedge's Profile: http://www.automotiveforums.com/vbul...p?userid=19971
View this thread: http://www.automotiveforums.com/vbul...d.php?t=696043

http://www.automotiveforums.com

  #3  
Old April 21st 07, 03:03 AM posted to rec.autos.tech
Steve Austin
external usenet poster
 
Posts: 106
Default MAF Sensor, I need help

Dennis wrote:
> My son drives a 1999 Escort ZX2 with the L4 2.0 liter engine. He was
> complaining that the car doesn't
> have as much power that it used to and that it idles rough. I connected my
> scan tool to check things out ( I'm new at this and far from an expert) and
> noticed that the mass air flow sensor was 2.7 volts at idle. The specs are
> .6-.9 volts.
> The calculated engine load was 59.2 % at idle. The long term fuel trim
> showed 2.3 %. There were no trouble codes set. Is this enough evidence to
> replace the MAF sensor? I hear they aren't cheap so I need a second opinion.
> Thanks so much for any help.
>
> Dennis
>
>

On a Ford MAF check the baro reading. Off more than 8hz from 159hz or
so (depending on where you live) clean or replace the MAF. A bad MAF
will usually show minus trims at idle and plus trims under load.
  #4  
Old April 21st 07, 09:22 PM posted to rec.autos.tech
Dennis[_2_]
external usenet poster
 
Posts: 56
Default MAF Sensor, I need help


"Dennis" > wrote in message
. ..
> My son drives a 1999 Escort ZX2 with the L4 2.0 liter engine. He was
> complaining that the car doesn't
> have as much power that it used to and that it idles rough. I connected my
> scan tool to check things out ( I'm new at this and far from an expert)
> and noticed that the mass air flow sensor was 2.7 volts at idle. The specs
> are .6-.9 volts.
> The calculated engine load was 59.2 % at idle. The long term fuel trim
> showed 2.3 %. There were no trouble codes set. Is this enough evidence to
> replace the MAF sensor? I hear they aren't cheap so I need a second
> opinion. Thanks so much for any help.
>
> Dennis
>


Thanks, for the responses. As soon as I can pin my boy down long enough to
work on his car I'll
try cleaning the MAF sensor and go from there.

Thanks again,
Dennis





 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0141 02 Sensor Heater Circuit Malfunction (Bank 1 Sensor 2) [email protected] BMW 9 February 21st 07 04:01 AM
'01 Toyota Avalon O2 sensor Bank1 Sensor 1 NewsGroups Technology 0 January 21st 07 05:57 PM
Where's O2 Sensor Bank 1 Sensor 1 for 1997 318is? liem00 BMW 5 January 15th 07 08:11 PM
camshaft positon sensor A bank 1/ verses knock sensor vita via CarKB.com Saturn 5 June 21st 06 06:57 PM
AWA [OFFER] Wheel sensor;Crankshaf position sensor;camshaft sensor;knock sensor;phase s [email protected] General 0 January 10th 06 01:51 PM


All times are GMT +1. The time now is 07:23 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 AutoBanter.
The comments are property of their posters.