A Cars forum. AutoBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » AutoBanter forum » Auto makers » Corvette
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

PING: DAD! question about c4 ecm problem



 
 
Thread Tools Display Modes
  #1  
Old October 13th 15, 12:41 PM posted to alt.autos.corvette
unclevito
external usenet poster
 
Posts: 14
Default PING: DAD! question about c4 ecm problem

On 9/16/2015 5:11 AM, wrote:
> I have a 1990 C4. base engine, 6 speed. All of a suddent it would
> start locking out my ignition as if it where reading my key chip as
> invalid. 5 minutes later it would reset and I could get it started
> agin. Suspected key switch but it always read good. Then it just shut
> down. No fuel pump, no turn over, nothing. Exaclty as anti theft would
> do but never reset. No codes from the ccm or ecm. Finally I changed
> out the ecm and bingo it started and ran fine. I did see to dark pins
> on one of the connectors. I cleaned them and hooked everything up and
> all was well, for about 2 weeks. This is not a dailey driver, but
> after approximatly 10 starts and stops it did it again. I had it towed
> home and again no codes and everything appeared fine. I replaced the
> ecm again and bang it started right back up. I am almost afraid to
> drive it now as I dont want to get starnded somewhere. I will probably
> buy a back up ecm so if it does ahppen again I can get home. I was
> just wondering if you might have an additional idea as to what to look
> for/check that may be a cause for this proble. I do have 107000 miles
> on it. I appreciate any help you can gie me.
> Thanks
> Ron
>



Go to
www.corvetteactioncenter.com and ask there.

Vito
Ads
  #2  
Old October 14th 15, 02:09 PM posted to alt.autos.corvette
[email protected]
external usenet poster
 
Posts: 5
Default PING: DAD! question about c4 ecm problem

Thanks for the info. I have registered and will see if they can help!

On Tue, 13 Oct 2015 04:41:39 -0700, unclevito
> wrote:

>On 9/16/2015 5:11 AM, wrote:
>> I have a 1990 C4. base engine, 6 speed. All of a suddent it would
>> start locking out my ignition as if it where reading my key chip as
>> invalid. 5 minutes later it would reset and I could get it started
>> agin. Suspected key switch but it always read good. Then it just shut
>> down. No fuel pump, no turn over, nothing. Exaclty as anti theft would
>> do but never reset. No codes from the ccm or ecm. Finally I changed
>> out the ecm and bingo it started and ran fine. I did see to dark pins
>> on one of the connectors. I cleaned them and hooked everything up and
>> all was well, for about 2 weeks. This is not a dailey driver, but
>> after approximatly 10 starts and stops it did it again. I had it towed
>> home and again no codes and everything appeared fine. I replaced the
>> ecm again and bang it started right back up. I am almost afraid to
>> drive it now as I dont want to get starnded somewhere. I will probably
>> buy a back up ecm so if it does ahppen again I can get home. I was
>> just wondering if you might have an additional idea as to what to look
>> for/check that may be a cause for this proble. I do have 107000 miles
>> on it. I appreciate any help you can gie me.
>> Thanks
>> Ron
>>

>
>
> Go to
www.corvetteactioncenter.com and ask there.
>
>Vito

 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PING: 2000 Caravan 3.0L V6 problem/question. Blondie Dodge 3 October 22nd 05 11:43 PM
update question on knock and ping Erik BMW 4 February 10th 05 03:52 AM
e36 Knock and ping question Erik BMW 1 February 3rd 05 01:48 AM
PING Gary.. TCC question Bret Chase 4x4 1 January 21st 05 07:04 PM


All times are GMT +1. The time now is 12:18 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 AutoBanter.
The comments are property of their posters.