A Cars forum. AutoBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » AutoBanter forum » Auto makers » Dodge
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

95 Dodge Neon with tons of problems



 
 
Thread Tools Display Modes
  #1  
Old September 19th 04, 07:09 PM
JBSham
external usenet poster
 
Posts: n/a
Default 95 Dodge Neon with tons of problems

I have had my 95 Dodge Neon for over 5 years now with no problems, other
than those I knew about when I bought it.
When I bought it the engine light was on and it had been checked and
they could not find anything wrong with it. It started coming on when
they previous owner replaced the engine. Sometimes the light goes off all
on its own and then a few days later it will come back on.
The lights behind the A/C controls are usually off but on a good day
those lights will decide to come on.
The lights on the gear shift were up until recently usually on. Now
they are usually off whenever I turn on the lights.
Since I purchased the car occasionaly the left turn signal light in my
car would come on as a constant light, but if I jiggled the turn signal up
a bit it would turn off. After I rotated my tires using my left turn
signal caused my caution lights to come on. My dashboard said that it was
a regular left signal only except when I would brake as far as my dashboard
lights were concerend my left turnsignal was a constant light, not a
flashing signal, and no matter how much I messed with the signal it
wouldn't fix itself. After a day this problem suddenly fixed itself.
This leads me to my current problem. After about 45minutes of driving
both highway and in town my engine heat needle went all the way up to the
H (past the mark) and the dashboard started beeping. As soon as I turned
off my headlights the alarm stopped. I turned the car off and when i
turned it back on after 10minutes or so the needle was at the 2/3rds
however when I turned on the lights it immediately shot up past the H
again. Now the lights don't seem to make a difference and its not doing
that again. There is no leaking so no hose has broken, the hood doesn't
feel hot and its definately not smokeing. Coolant is filled, and just had
an oil chnage. I can get the needle to go back down if I turn on my heat,
but I am not sure if I were to leave it running for longer if the needle
would just go to the top again. While sitting still and without any
inside fans on the car going after around 20minutes the needle went past
the H again, sat there for a little while and suddenly started dropping.
I have no idea what is going on. I understand a bit about cars but this
is way past me. I recently moved as well so I don't know what shop to
take it to in the area.
Any suggestions? Sorry such a long post but I am secretly hoping its an
electrical problem and the engine isn't overheating. Or its just
something super cheap.
Thank you!
~Andrea

Ads
  #2  
Old November 7th 04, 05:00 AM
dragon
external usenet poster
 
Posts: n/a
Default

More than likely, the problem is in the wiring harness. check the
recall notices. any manufactured in mexico had problems.

On Sun, 19 Sep 2004 14:09:22 -0400, "JBSham"
> wrote:

>I have had my 95 Dodge Neon for over 5 years now with no problems, other
>than those I knew about when I bought it.
> When I bought it the engine light was on and it had been checked and
>they could not find anything wrong with it. It started coming on when
>they previous owner replaced the engine. Sometimes the light goes off all
>on its own and then a few days later it will come back on.
> The lights behind the A/C controls are usually off but on a good day
>those lights will decide to come on.
> The lights on the gear shift were up until recently usually on. Now
>they are usually off whenever I turn on the lights.
> Since I purchased the car occasionaly the left turn signal light in my
>car would come on as a constant light, but if I jiggled the turn signal up
>a bit it would turn off. After I rotated my tires using my left turn
>signal caused my caution lights to come on. My dashboard said that it was
>a regular left signal only except when I would brake as far as my dashboard
>lights were concerend my left turnsignal was a constant light, not a
>flashing signal, and no matter how much I messed with the signal it
>wouldn't fix itself. After a day this problem suddenly fixed itself.
> This leads me to my current problem. After about 45minutes of driving
>both highway and in town my engine heat needle went all the way up to the
>H (past the mark) and the dashboard started beeping. As soon as I turned
>off my headlights the alarm stopped. I turned the car off and when i
>turned it back on after 10minutes or so the needle was at the 2/3rds
>however when I turned on the lights it immediately shot up past the H
>again. Now the lights don't seem to make a difference and its not doing
>that again. There is no leaking so no hose has broken, the hood doesn't
>feel hot and its definately not smokeing. Coolant is filled, and just had
>an oil chnage. I can get the needle to go back down if I turn on my heat,
>but I am not sure if I were to leave it running for longer if the needle
>would just go to the top again. While sitting still and without any
>inside fans on the car going after around 20minutes the needle went past
>the H again, sat there for a little while and suddenly started dropping.
>I have no idea what is going on. I understand a bit about cars but this
>is way past me. I recently moved as well so I don't know what shop to
>take it to in the area.
>Any suggestions? Sorry such a long post but I am secretly hoping its an
>electrical problem and the engine isn't overheating. Or its just
>something super cheap.
>Thank you!
> ~Andrea


  #3  
Old November 7th 04, 05:00 AM
dragon
external usenet poster
 
Posts: n/a
Default

More than likely, the problem is in the wiring harness. check the
recall notices. any manufactured in mexico had problems.

On Sun, 19 Sep 2004 14:09:22 -0400, "JBSham"
> wrote:

>I have had my 95 Dodge Neon for over 5 years now with no problems, other
>than those I knew about when I bought it.
> When I bought it the engine light was on and it had been checked and
>they could not find anything wrong with it. It started coming on when
>they previous owner replaced the engine. Sometimes the light goes off all
>on its own and then a few days later it will come back on.
> The lights behind the A/C controls are usually off but on a good day
>those lights will decide to come on.
> The lights on the gear shift were up until recently usually on. Now
>they are usually off whenever I turn on the lights.
> Since I purchased the car occasionaly the left turn signal light in my
>car would come on as a constant light, but if I jiggled the turn signal up
>a bit it would turn off. After I rotated my tires using my left turn
>signal caused my caution lights to come on. My dashboard said that it was
>a regular left signal only except when I would brake as far as my dashboard
>lights were concerend my left turnsignal was a constant light, not a
>flashing signal, and no matter how much I messed with the signal it
>wouldn't fix itself. After a day this problem suddenly fixed itself.
> This leads me to my current problem. After about 45minutes of driving
>both highway and in town my engine heat needle went all the way up to the
>H (past the mark) and the dashboard started beeping. As soon as I turned
>off my headlights the alarm stopped. I turned the car off and when i
>turned it back on after 10minutes or so the needle was at the 2/3rds
>however when I turned on the lights it immediately shot up past the H
>again. Now the lights don't seem to make a difference and its not doing
>that again. There is no leaking so no hose has broken, the hood doesn't
>feel hot and its definately not smokeing. Coolant is filled, and just had
>an oil chnage. I can get the needle to go back down if I turn on my heat,
>but I am not sure if I were to leave it running for longer if the needle
>would just go to the top again. While sitting still and without any
>inside fans on the car going after around 20minutes the needle went past
>the H again, sat there for a little while and suddenly started dropping.
>I have no idea what is going on. I understand a bit about cars but this
>is way past me. I recently moved as well so I don't know what shop to
>take it to in the area.
>Any suggestions? Sorry such a long post but I am secretly hoping its an
>electrical problem and the engine isn't overheating. Or its just
>something super cheap.
>Thank you!
> ~Andrea


  #4  
Old November 7th 04, 12:55 PM
maxpower
external usenet poster
 
Posts: n/a
Default

The reason why your lite is staying on the t/s is because the flasher knob
it causing it, there was a TSB for replecing the T?S switch for that
problem....when the temp gauge shoots up is the car OVERHEATING??? does the
radiator fan turn on??
"JBSham" > wrote in message
lkaboutautos.com...
> I have had my 95 Dodge Neon for over 5 years now with no problems, other
> than those I knew about when I bought it.
> When I bought it the engine light was on and it had been checked and
> they could not find anything wrong with it. It started coming on when
> they previous owner replaced the engine. Sometimes the light goes off all
> on its own and then a few days later it will come back on.
> The lights behind the A/C controls are usually off but on a good day
> those lights will decide to come on.
> The lights on the gear shift were up until recently usually on. Now
> they are usually off whenever I turn on the lights.
> Since I purchased the car occasionaly the left turn signal light in my
> car would come on as a constant light, but if I jiggled the turn signal up
> a bit it would turn off. After I rotated my tires using my left turn
> signal caused my caution lights to come on. My dashboard said that it was
> a regular left signal only except when I would brake as far as my

dashboard
> lights were concerend my left turnsignal was a constant light, not a
> flashing signal, and no matter how much I messed with the signal it
> wouldn't fix itself. After a day this problem suddenly fixed itself.
> This leads me to my current problem. After about 45minutes of driving
> both highway and in town my engine heat needle went all the way up to the
> H (past the mark) and the dashboard started beeping. As soon as I turned
> off my headlights the alarm stopped. I turned the car off and when i
> turned it back on after 10minutes or so the needle was at the 2/3rds
> however when I turned on the lights it immediately shot up past the H
> again. Now the lights don't seem to make a difference and its not doing
> that again. There is no leaking so no hose has broken, the hood doesn't
> feel hot and its definately not smokeing. Coolant is filled, and just had
> an oil chnage. I can get the needle to go back down if I turn on my heat,
> but I am not sure if I were to leave it running for longer if the needle
> would just go to the top again. While sitting still and without any
> inside fans on the car going after around 20minutes the needle went past
> the H again, sat there for a little while and suddenly started dropping.
> I have no idea what is going on. I understand a bit about cars but this
> is way past me. I recently moved as well so I don't know what shop to
> take it to in the area.
> Any suggestions? Sorry such a long post but I am secretly hoping its an
> electrical problem and the engine isn't overheating. Or its just
> something super cheap.
> Thank you!
> ~Andrea
>



  #5  
Old November 7th 04, 12:55 PM
maxpower
external usenet poster
 
Posts: n/a
Default

The reason why your lite is staying on the t/s is because the flasher knob
it causing it, there was a TSB for replecing the T?S switch for that
problem....when the temp gauge shoots up is the car OVERHEATING??? does the
radiator fan turn on??
"JBSham" > wrote in message
lkaboutautos.com...
> I have had my 95 Dodge Neon for over 5 years now with no problems, other
> than those I knew about when I bought it.
> When I bought it the engine light was on and it had been checked and
> they could not find anything wrong with it. It started coming on when
> they previous owner replaced the engine. Sometimes the light goes off all
> on its own and then a few days later it will come back on.
> The lights behind the A/C controls are usually off but on a good day
> those lights will decide to come on.
> The lights on the gear shift were up until recently usually on. Now
> they are usually off whenever I turn on the lights.
> Since I purchased the car occasionaly the left turn signal light in my
> car would come on as a constant light, but if I jiggled the turn signal up
> a bit it would turn off. After I rotated my tires using my left turn
> signal caused my caution lights to come on. My dashboard said that it was
> a regular left signal only except when I would brake as far as my

dashboard
> lights were concerend my left turnsignal was a constant light, not a
> flashing signal, and no matter how much I messed with the signal it
> wouldn't fix itself. After a day this problem suddenly fixed itself.
> This leads me to my current problem. After about 45minutes of driving
> both highway and in town my engine heat needle went all the way up to the
> H (past the mark) and the dashboard started beeping. As soon as I turned
> off my headlights the alarm stopped. I turned the car off and when i
> turned it back on after 10minutes or so the needle was at the 2/3rds
> however when I turned on the lights it immediately shot up past the H
> again. Now the lights don't seem to make a difference and its not doing
> that again. There is no leaking so no hose has broken, the hood doesn't
> feel hot and its definately not smokeing. Coolant is filled, and just had
> an oil chnage. I can get the needle to go back down if I turn on my heat,
> but I am not sure if I were to leave it running for longer if the needle
> would just go to the top again. While sitting still and without any
> inside fans on the car going after around 20minutes the needle went past
> the H again, sat there for a little while and suddenly started dropping.
> I have no idea what is going on. I understand a bit about cars but this
> is way past me. I recently moved as well so I don't know what shop to
> take it to in the area.
> Any suggestions? Sorry such a long post but I am secretly hoping its an
> electrical problem and the engine isn't overheating. Or its just
> something super cheap.
> Thank you!
> ~Andrea
>



 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuse problems Dodge Neon Carolyn1111 Dodge 2 September 12th 04 03:39 AM
dodge neon starting problems. bams10 Dodge 8 May 8th 04 03:50 PM


All times are GMT +1. The time now is 07:56 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 AutoBanter.
The comments are property of their posters.